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Microsoft FrontPage 

I.  Pendahuluan 

Pada dasarnya tahapan untuk membuat dan update website adalah sebagai berikut: 

- membuat/update/edit halaman website dengan ms FrontPage secara offline, dengan menyimpan 

seluruh file pngerjaan dalam satu folder tertentu dalam hardisk komputer kita, misal C:\my 

documents\b.heru’s web 

- proses upload ke server dengan menggunakan webft atau winscp, dengan cara memindahkan 

semua file (pada tahap awal) atau sebagian file yang diupdate/edit ke server (pada tahap 

maintenance), dengan format penyusunan file (termasuk susunan dan nama folder) yang sama 

dengan yang ada di hardisk komputer. Contoh seluruh file (termasuk folder) yang ada didalam 

C:\my documents\b.heru’s web dipindahkan ke folder public_html pada area alamat website 

kita. 

II. Mengenal Microsoft FrontPage 

Microsoft FrontPage (MS FrontPage) adalah sebuah program untuk membuat, mendesain, dan mengedit 

halaman World Wide Web seperti menambahkan text,images, table, form, dan elemen lain di halaman 

Web. MS FrontPage menampilkan itu semua seperti apa yang ditampilkan di Web browser. Secara 

otomatis file akan menjadi sebuah kode HTML (Hyper Text MarkUp Language).  

Dapat dilihat beberapa fasilitas yang ada sama seperti yang ada pada MS Word maupun MS Excel seperti 

Title Bar, Menu Bar, dan lainnya. 

Cara untuk membuka, menyimpan, dan menutup MS FrontPage sama juga dengan program MS Office 

lainnya. 

III.  Membuat tampilan website dari permulaan 

Sebelum kita membuka program Microsoft Frontpage 2003, kita siapkan dahulu sebuah direktori baru 

untuk tempat file web yang akan kita buat, misalkan di : C:\my documents\b.heru’s web 

Selanjutnya kita mulai menggunakan FrontPage, jalankan dari window Start � All Program � Microsoft 

office � Microsoft FrontPage 
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Kemudian akan muncul tampilan frontpage editor seperti pada gambar.  

 

Klik pada bagian  � sehingga muncul tampilan berikut : 
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Klik bagian , klik lagi bagian Frames Pages, sehingga akan memunculkan tampilan 

berikut: 

 

Pilih salah satu tampilan frame yang disukai untuk menjadi format website kita, kemudian klik OK. 

Kemudian kita akan dapatkan tampilan sebagai berikut 
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Save ke folder yang telah kita siapkan (misal : C:\my documents\b.heru’s web) dengan nama index.html 

(ingat khusus untuk halaman yang berisikan frame untuk format website yang kita inginkan harus disimpan 

dengan nama index.html tidak boleh nama yang lain !) 
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Setelah itu untuk mengisi 3 frame yang telah tersedia dalam file index.html, maka kita buat 3 halaman baru. 

Untuk membuat sebuah halaman baru di MS FrontPage, gunakan perintah File > New pada menu atau 

Ctrl + N, maka akan muncul kotak dialog. Page templates akan berisi modul-modul web yang sudah jadi 

dan tinggal melakukan edit, sedangkan normal page berupa halaman kosong. 

Contoh:  

dengan cara mengklik lambang  (atau klik file � new) 3 kali berturut-turut, kemudian masing-masing 

disave ke folder yang telah kita siapkan (c:\my documents\b.heru’s web) dengan nama file (nama file bebas 

terserah kita), misal : main_menu, judul, dan halaman_utama. Sehingga dihasilkan tampilan berikut: 

 

Setelah itu kembali ke index html 
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Kemudian klik secara bertahap bagian  pada masing-masing frame dan hubungkan 

masing-masing frame dengan masing-masing halaman yang telah kita buat, missal bagian kiri dengan 

main_menu.htm, bagian atas dengan judul.htm dan bagian bawah (frame terbesar) dengan 

halaman_utama_htm 

Contoh untuk bagian paling kanan 

 

Ketik OK sehingga didapat tampilan: 
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Dan setelah semua frame terisi halaman maka akan didapat tampilan: 
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Selesai sudah untuk tahap awal membuat halaman muka website. 

Langkah selanjutnya adalah mengisi halaman-halaman tersebut dengan tulisan, image (foto, gambar dsb), 
dll, dimana perubahan di halaman-halaman menu_utama.htm, judul.htm dsb akan otomatis terlihat juga 
pada index.html begitu pula sebaliknya (silahkan coba). Yang perlu diperhatikan: 

- Jangan lupa selalu disave masing-masing halaman setiap ada perubahan.  

- Tempatkan semua image (foto, gambar), dokumen (biasanya kalau akan didownload langsung) 
dalam folder yang telah kita siapkan (misal C:\my documents\b.heru’s web) 

Contoh yang sudah jadi:  
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Untuk melihat setiap hasilnya kita bisa melihatnya dengan frontpage maupun dengan browser seperti 

Internet Explorer, Mozilla FireFox, Netscape Navigator maupun browser lainnya. Gambar di bawah ini 
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merupakan hasil dari web yang telah kita buat dengan menggunakan browser Internet Explorer dengan 

langkah-langkah : klik File – Open – Browse – cari nama file di direktori tempat file disimpan. 

 

IV. Tips dan Trik 

A.  Menempatkan Hyperlink pada halaman Web 

Hyperlink merupakan bagian penting pada Homepage atau halaman Web. Dengan menggunakan 

hyperlink, informasi-informasi pada halaman Web dapat dihubungkan, juga dapat menghubungkan 

halaman Web yang lain. 

Cara untuk menempatkan hyperlink adalah klik menu Insert > Hyperlink (Ctrl + K) sehingga muncul kotak 

dialog Create Hyperlink seperti pada Gambar . 

 

Gambar7. Kotak dialog Create Hyperlink 

Kemudian lakukan pengisian dan pengaturan seperti: 

• Look in: pilih dan klik driver atau folder tempat file yang ingin dihubungkan tersimpan, kemudian 

pada kotak daftar pilihan dibawahnya pilih dan double klik nama file yang diinginkan. 

• URL: ketikkan alamat halaman Web atau nama file yang ingin dihubungkan kemudian klik OK. 

• Make a hyperlink to a file on your computer: untuk membuat sebuah hubungan file yang 

tersimpan kemudian klik OK. 
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• Use tour Web Browse to select a page or file: untuk memilih halaman Web atau file denagn 

menggunakan Web Browser yang terpasang. 

• Make a hyperlink that sends E-mail: untuk membuat sebuah hubungan guna mengirim E-mail. 

• Create a page ang link to that new page: untuk membuat dan menghubungkan link dengan 

sebuah halaman Web baru. 

Atau dapat juga dengan cara menyorot tulisan atau gambar, kilk kanan dan pilih Hyperlink. 

B. Komponen yang disediakan Frontpage 

Di dalam Frontpage terdapat komponen-komponen yang telah siap pakai yang dapat dipakai oleh 

perancang untuk dimuat di sebuah halaman ke dalam web browser. Komponen-komponen ini 

menyediakan cara yang cepat dan mudah untuk digunakan tanpa harus mempelajari penulisan script atau 

pemrograman ActiveX dan Java. Komponen-komponen tersebut adalah: 

 

1. Comment 

Komponen ini sangat berguna pada saat membangun situs web. Comment ini merupakan komentar yang 

disisipkan ke dalam kode HTML untuk menjelaskan beberapa aspek perancangan atau pengkodean. 

Komentar ini tidak akan terlihat ketika halaman ditampilkan di dalam browser. 

2. Page Banner 
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Menyisipkan banner grafik di bagian atas sebuah halaman web 

3. Banner Ad Manager 

Merotasi tampilan beberapa gambar pada interval yang ditentukan. Memungkinkan untuk memilih tipe 

transisi antar banner (dissolve, horizontal blinds, dsb) dan menghubungkan banner ke suatu halaman web. 

4. Hit counter 

Menampilkan berapa kali halaman telah dikunjungi, atau “hit”. 

5. Hover Button 

Menyisipkan sebuah link yang menampilkan efek visual ketika pointer mouse “mengambang,” atau 

ditempatkan di atasnya. Efek ini termasuk perubahan warna dan penampilan yang menyerupai tombol 

tertekan. 

6. Marquee 

Menampilkan teks yang menggulung secara horizontal di halaman web. 

7. Confirmation Field 

Meminta konfirmasi atas masukan yang diberikan pemakai pada form halaman web. 

8. Include Page 

Menyisipkan satu halaman web pada lokasi yang ditentukan dalam halaman lain. Sebagai contoh, mungkin 

ingin  menyisipkan halaman hak cipta di bagian bawah setiap halaman dalam web Anda.  

9. Scheduled Picture 

Menampilkan gambar untuk periode waktu yang ditentukan dan menggantinya dengan gambar lain. 

Berguna untuk menampilkan informasi yang berkaitan dengan waktu, seperti icon “New” pada halaman 

baru. 

10. Schedule Include Page 

Menyisipkan satu halaman web dalam halaman lain untuk periode waktu tertentu dan menggantikannya 

pada suatu waktu yang gitentukan. Berguna untuk menampilkan informasi yang berkaitan dengan waktu, 

seperti informasi tentang perkuliahan. 

11. Substitution 
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Mengganti bagian teks dengan nilai yang ditentukan, misalnya teks lainnya. 

12. Categories 

Menyisipkan link ke halaman berdasarkan kategori. Berguna untuk membuat daftar isi untuk halaman jenis 

tertentu, misalnya laporan anggaran atau perencanaan. 

13. Search form 

Memungkinkan pengunjung mencari teks dalam web site. Jika Anda menyimpan sebuah halaman dengan 

form search, Frontpage akan membuat sebuah indeks dari web site. Ketika pemakai melakukan pencarian, 

Frontpage memakai indeks untuk membuat daftar hyperlink ke halaman-halaman yang berisi kata atau 

frase yang dia cari. 

14. Table of Contents 

Membuat daftar isi untuk web site. 

 

C.  Menempatkan teks bergerak (Marquee) 

Untuk menampilkan halaman homepage agar menarik dengan menggunakan teks yang bergerak 

(Marquee), dapat dilakukan dengan cara menempatkan sisip pada posisi yang diinginkan, kemudian pilih 

dan klik menu Insert > Web Component sehingga muncul kotak dialog Insert Web Component. Pilih 

Marquee, kemudian klik tombol Finish. Setelah itu akan muncul kotak dialog Marquee Properties seperti 

pada Gambar 8. Pada kotak dialog tersebut, lakukan pengisisan dan pengaturan berikut ini: 

• Text: diisi dengan teks yang ingin ditampilkan. 

• Direction: digunakan untuk mengatur arah pergerakan teks. 

• Speed: digunakan untuk mengatur kecepatan pergerakan teks. 

• Size: digunakan untuk mengatur ukuran teks. 

• Repeat: digunakan untuk mengatur berapa kali pergerakan teks yang ingin dilakukan. 

• Background Color: digunakan untuk memilih warna latar belakang pergerakan teks. 

• Style: digunakan untuk pengaturan teks seperti bingkai, jenis huruf, warna, dan lain-lain. 
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Gambar 8. Kotak dialog Marquee Properties 

D.  Memberi latar belakang (Background) pada page 

Klik menu Format > Backgroud (atau klik kanan mouse) sehingga kotak dialog Page Properties  

muncul seperti pada Gambar dibawah. Pilih tab Backgroud kemudian lakukan pemilihan dan pengaturan 

seperti: 

• Tombol daftar pilihan background, pilih dan klik warna yang diinginkan. 

• Text, pilih dan klik warna teks hyperlink yang diinginkan. 

• Visited hyperlink, pilih dan klik warna teks hyperlink yang sudah dikunjungi. 

• Tombol Active Hyperlink, pilih dan klik warna hyperlink aktif yang diinginkan. 
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Gambar. Kotak dialog Page Properties 

Bagian Formatting beri tanda atau klik kotak Background Picture bila ingin mengambil gambar untuk 

ditempatkan sebagai latar belakang, kemudian klik Browse, pilih file gambar, klik OK. 

Jika ingin mengambil motif dan warna latar belakang dari halaman web lain, beri tanda atau klik kotak Get 

background information from another page, kemudian klik Browse untuk memilih halaman web yang 

diinginkan. 

E. Mengatur tampilan halaman Web dengan memanfaatkan format Themes 

Themes dapat menghidupkan halaman web, karena fasilitas ini mempunyai koleksi elemen-elemen desain 

seperti bullets, background patterns, table borders, fonts, dan graphics yang semuanya dapat dimasukkan 

ke halaman web. Dengan menempatkan Format Themes pada home page dan pada seluruh halaman 

webnya, situs web akan lebih konsisten dan struktur navigasi akan terlihat lebih professional.  

Cara untuk memanfaatkan Format Themes yaitu klik menu Format > Themes sehingga kotak dialog 

Themes muncul seperti pada Gambar. Kemudian lakukan pemilihan dan pengaturan berikut ini: 

• All pages: apabila menginginkan format themes ditempatkan pada seluruh halaman web. 

• Selected page: apabila menginginkan format themes ditempatkan hanya pada halaman web yang 

di pilih saja. 
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• Kotak daftar pilihan themes klik Format Themes sesuai dengan yang diinginkan pada kotak 

Sample of Theme akan tampil bentuk formatnya.  

Jika diperlukan, dapat menampilkan atau menghilangkan komponen themes dengan: 

• Klik kotak cek Vivid colors untuk menampilkan warna yang lebih hidup pada theme. 

• Klik kotak cek Active graphics untuk menampilkan aktif grafik pada theme. 

• Klik kotak cek Backgroud pictures untuk menampilkan motif latar belakang pada theme. 

• Tombol Modify dilakukan untuk mengubah dan memodifikasi format tampilan theme yang ada. 

 

Gambar. Kotak dialog Themes 

F.  Memberi efek transisi perpindahan halaman Web (Page Transition) 

Caranya adalah dengan klik menu Format > Transition sehingga kotak dialog Page Transition muncul 

seperti pada Gambar 6. Kemudian lakukan pengisian berikut: 

• Event: pilih dan klik pada saat kapan efek transisi perpindahan halaman Web akan ditampilkan. 

• Transition Effect: pilih dan klik efek transisi yang diinginkan. 

• Duration: ketik waktu durasi yang diinginkan. 
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Gambar 6. Kotak dialog Page Transition 

G.  Menempatkan objek gambar (Clip Art) 

Untuk menyisipkan atau menempatkan objek gambar (Clip Art) pada halamana Web, dapat dilakukan 

dengan cara yang sama seperti pada MS Word. 

H.  Menempatkan banner dengan fasilitas Banner Ad Manager 

Caranya adalah dengan klik menu Insert > Web Component sehingga muncul kotak dialog Insert Web 

Component. Pilih Banner Ad Manager, kemudian klik tombol Finish. Setelah itu akan muncul kotak 

dialog Banner Ad Manager Properties seperti pada Gambar . 

 

Gambar . Kotak dialog Banner Ad Manager properties 
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Pada kotak dialog tersebut, lakukan pengisian dan pengaturan berikut ini: 

• Width dan Height: diisi dengan lebar (width) dan tinggi (height) banner yang diinginkan. 

• Transition effect: digunakan untuk memilih efek transisi perpindahan gambar atau image yang 

diinginkan. 

• Show each picture for (seconds): diisi jangka waktu penampilan gambar sebelum berpindah ke 

tampilan gambar atau image lain. 

• Link to: diisi dengan link yang diinginkan. Misalnya apabila mengklik banner tersebut, halaman 

Web tertentu langsung terbuka. 

• Picture to display: digunakan untuk mengatur gambar atau image yang akan ditampilkan. 

 

I.  Menempatkan tombol link dengan Hover Button 

Cara yang digunakan adalah dengan klik menu Insert > Web Component sehingga muncul kotak dialog 

Insert Web Component. Pilih Hover Button, kemudian klik tombol Finish. Setelah itu akan muncul kotak 

dialog Hover Button Properties seperti pada Gambar  

 

Gambar  kotak dialog Hover Button properties 

J. Bekerja dengan Tabel 
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Agar tampilan website tampak bagus sebaiknya gunakan tabel. Untuk membuat tabel caranya adalah klik 

menu Table > Insert > Table atau klik tombol di toolbar sehingga muncul kotak dialog seperti pada 

Gambar . 

 

Gambar . Kotak dialog Insert Table 

Pada kotak dialog tersebut, lakukan pengisian dan pengaturan berikut ini: 

• Rows: untuk menentukan banyaknya baris pada tabel. 

• Columns: untuk menentukan banyaknya kolom pada tabel. 

• Alignment: untuk mengatur alignment pada tabel. 

• Border size: untuk mengatur ketebalan garis yang membentuk tabel. 

• Cell padding: untuk mengatur jarak antar isi sel dengan garis pada sel. 

• Cell spacing: untuk mengatur jarak antar sel pada tabel. 

• Specify width: untuk menentukan spesifikasi lebar tabel. 

• Set as default for new table: kotak cek yang digunakan untuk menentukan pangaturan tabel 

secara default. 

Untuk lebih jelasnya lihat gambar dibawah ini: 



FrontPage - BambangHS 

 21 

 


